Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 13, 2026 - 03:30 UTC
Scheduled
Rolling upgrade of all EKS-managed node groups to the latest AMI to patch CVE-2026-31431 ("Copy Fail") — a critical Linux kernel privilege escalation vulnerability (CVSS 7.8). Nodes will be replaced in a rolling fashion. Some nodes may require manual intervention due to PDB constraints. Minimal service disruption expected.
Posted May 12, 2026 - 14:34 UTC
This scheduled maintenance affected: North America and EMEA.